550 Water Pump

Forum for the discussion of Oliver related topics.

550 Water Pump

Postby eddievalleytrailer » Tue Oct 20, 2015 10:47 pm

I'm new to Olivers and to this forum. I just bought a 1964 550 with a leaking water pump. The only one I see is for a sheet metal pulley. Mine has a cast iron pulley. The listing for the sheet metal one says it will not work in place of the cast pulley. What to do? My s/n is 140719. I did find one with the same casting number as mine but the picture shows no pulley at all and I see no way to take my old pulley off of the pump.
eddievalleytrailer
 
Posts: 7
Joined: Tue Oct 20, 2015 10:12 pm

water

Postby chucksoliver77 » Wed Oct 21, 2015 2:25 pm

Eddie, It looks like there is a snap ring right inside where the fan bolts on?????????? Post on the Oliver forum on yesterdays tractor to get a more qualified answer. Chuck
chucksoliver77
 
Posts: 62
Joined: Sun Nov 08, 2009 8:12 pm
Location: newton,nj

Postby John Schwiebert » Wed Oct 21, 2015 9:37 pm

The pulley is pressed off and on. Post an e-mail address. There are at least 3 different 550 water pumps and several different pulleys.
John Schwiebert
 
Posts: 867
Joined: Tue Dec 31, 2002 3:24 pm

Pump found and installed!!!

Postby eddievalleytrailer » Thu Oct 22, 2015 10:04 pm

For future reference, the p/n was 160927AS. The casting was a little rough and required a little grinding around the top edge but seems to be working fine. Before I started this project it required to be run on about half choke to run at higher RPMs. So, I rebuilt the carb. It's still doing the same thing. I've had it on and off 4 times checking and rechecking everything to no luck. It takes gas just fine when letting off the clutch from idle but stalls out when above 1000 rpms. Ideas?
eddievalleytrailer
 
Posts: 7
Joined: Tue Oct 20, 2015 10:12 pm

Postby Terry » Fri Oct 23, 2015 12:53 pm

Sounds like a vacuum leak somewhere on the intake manifold-maybe at head or carb?
Terry
 
Posts: 145
Joined: Tue Nov 26, 2002 6:55 pm
Location: Abingdon, IL

Postby eddievalleytrailer » Fri Oct 23, 2015 2:36 pm

I thought of that but when I put my hand over the intake is stalls right out and would suck a baseball through a garden hose. Usually, I've found with a vacuum leak it would keep running or make a big sucking sound when the air intake is closed off. The carb does (maybe) have one issue. The long tube from the load adjustment screw that runs to the center of the carb is stuck and will not come out. It looks clear but don't most of those have small holes in the sides which may be clogged?
eddievalleytrailer
 
Posts: 7
Joined: Tue Oct 20, 2015 10:12 pm


Return to Oliver Forum

Who is online

Users browsing this forum: No registered users and 5 guests

cron